ウケるデジモノブログ|smiley-jp

デジモノをこよなく愛するブログ

kamiz | | ブログ

  • このエントリーをはてなブックマークに追加
  • LINEで送る
  • follow us in feedly

movabletype 3.2 日本語版へアップグレード!そしたら500エラー連発!ショック!

six apartより「Movable Type 3.2日本語版」がリリースされました。早速ダウンロードして、アップグレードしました。

管理ページへアクセスすると自動的にアップグレードが始まります。完了したところで、新規エントリーの投稿。「公開」に設定して「保存」をクリック。そしたらなんと!

500 Error -Internal Sever Error-
CGIもしくはSSIが正しく動作していません。

どうやらCGIの動作不良だそうで、原因はパーミッション設定かアップロードミスだそうです。

なんとしたことか!アップグレードをミスった~!

でも、下書き保存してから、インデックスページを再構築すれば、記事はブログに反映されます。
ということはほかのCGIは動作しているということ!?バイナリでアップロードしてるよ!?ロリポップの設定どおりにパーミッション設定したよ!?

movabletype 3.2 にアップグレードしてから、500エラー多発しているかたが多いらしいです。
オイラも現在ググって調査中。しかたないので、バックアップとって、インストールし直すか。

追記
結局 MovableType 3.2 をすべて削除して再インストールしました。
参考にさせていただいたサイト:【MovableTypeで行こう!】 インストールしよう(ロリポップ編) Ver3.2-ja対応版
さっそく、six apart から「 MT-3.2-ja 」をダウンロードし解凍。
解凍してできた mt-config.cgi-original ファイルを、mt-config.cgi にリネーム。(-originalを削除するだけでOK)
どうやら、リネームせずにアップグレードしてしまったのが問題だったようです。
(アップグレード後にリネームするとシステムエラーみないな事になってしまいます。)
このへんも MovableType の敷居が高いといわれる原因でしょうか。
とにもかくにもdbフォルダのバックアップは必須です。(やっててよかった。)

こちらの記事も役に立ちます

スポンサーリンク